Packages for keyword “json”
These packages are available as a package collection, usable in Xcode or SwiftPM.
EagleNet
Simple lightweight networking layer written on top of URLSession. This will provide a clean, separate layer for networking.
FeatureFlags
🚩 Allows developers to configure feature flags, run multiple A/B tests or phase feature roll out using a JSON configuration file.
Marshal
Marshaling the typeless wild west of [String: Any]
PMJSON
Pure Swift JSON encoding/decoding library
Scout
Reading and writing in JSON, Plist, YAML and XML data made simple when the data format is not known at build time. Swift library and command-line tool.
DynamicJSON
Framework for representing, validating, querying, and manipulating generic JSON values in Swift 6. Supported are standards such as JSON Text Sequences (RFC 7464), JSON Pointer (RFC 6901), JSON Path (RFC 9535), JSON Patch (RFC 6902), JSON Merge Patch (RFC 7396), and JSON Schema.
universal
Tiny zero-dependency cross-platform Swift parsers for JSON, XML, YAML, and PLIST including in-memory interchange formats and Either type
Configuration
Hierarchical configuration manager for Swift applications
ws
⚠️ Deprecated - (in favour of Networking) :cloud: Elegantly connect to a JSON api. (Alamofire + Promises + JSON Parsing)
SmartNetwork
Light weight wrapper around URLSession
Ananda
JSON model decoding based on yyjson.
Baby
Create models from a JSON file, even a Baby can do it.
GenericJSON
A simple Swift library for working with generic JSON structures
Gloss
[Deprecated] A shiny JSON parsing library in Swift :sparkles: Loved by many from 2015-2021
jmespath.swift
Swift implementation of JMESPath, the JSON query language
JSONPreview
🎨 A view that previews JSON in highlighted form, it also provides the ability to format and collapse nodes.
JSONValue
A container type for generic, untyped JSON data.
Localize
Localize is a framework writed in swift to localize your projects easier improves i18n, including storyboards and strings.
MacroCodableKit
Boilerplate-free Codable for Swift. Supports AllOf / OneOf (OpenAPI), adjacently tagged enums, custom coding keys, default values, and value strategies — all via macros with zero runtime overhead
swift-extras-json
JSON encoding and decoding without the use of Foundation in pure Swift.