This is a staging environment. For live and up-to-date package information, visit swiftpackageindex.com.

The Swift Package Index logo.Swift Package Index

How many packages are compatible with Swift 6? Find out which packages are Ready for Swift 6!

When working with an Xcode project:

When working with a Swift Package Manager manifest:

Select a package version:

2.0.1

develop


A Swift package for simple dependency injection that also supports Swift UI previews.

ptrkstr welcomes support for Injector through GitHub Sponsors and Ko-fi. If you find this package useful, please consider supporting it.


Compatibility

Full Build Results



This is a staging environment. For live and up-to-date package information, visit swiftpackageindex.com.