This is a staging environment. For live and up-to-date package information, visit swiftpackageindex.com.

The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build BlackLabsSwiftUIColor with Swift 5.9 for Linux.

Build Command

docker run --rm -v "checkouts-4606859-1":/host -w "/host/spi-builder-workspace" registry.gitlab.com/finestructure/spi-images:basic-5.9-latest swift build 2>&1

Build Log

========================================
RunAll
========================================
Builder version: 4.23.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/nbasham/BlackLabsSwiftUIColor.git
Reference: 1.1.2
Cloned https://github.com/nbasham/BlackLabsSwiftUIColor.git into spi-builder-workspace
SUCCESS checkout https://github.com/nbasham/BlackLabsSwiftUIColor.git at 1.1.2
========================================
Build
========================================
Selected platform:         linux
Swift version:             5.9
Building package at path:  spi-builder-workspace
Running build ...
docker run --rm -v "checkouts-4606859-1":/host -w "/host/spi-builder-workspace" registry.gitlab.com/finestructure/spi-images:basic-5.9-latest swift build 2>&1
Building for debugging...
error: emit-module command failed with exit code 1 (use -v to see invocation)
[1/3] Emitting module BlackLabsSwiftUIColor
/host/spi-builder-workspace/Sources/BlackLabsSwiftUIColor/BlackLabsSwiftUIColor.swift:24:8: error: no such module 'SwiftUI'
import SwiftUI
       ^
[2/3] Compiling BlackLabsSwiftUIColor UserDefaults+Color.swift
/host/spi-builder-workspace/Sources/BlackLabsSwiftUIColor/BlackLabsSwiftUIColor.swift:24:8: error: no such module 'SwiftUI'
import SwiftUI
       ^
[3/3] Compiling BlackLabsSwiftUIColor BlackLabsSwiftUIColor.swift
/host/spi-builder-workspace/Sources/BlackLabsSwiftUIColor/BlackLabsSwiftUIColor.swift:24:8: error: no such module 'SwiftUI'
import SwiftUI
       ^
error: fatalError
BUILD FAILURE 5.9 linux

Build Machine: Linux 1

This is a staging environment. For live and up-to-date package information, visit swiftpackageindex.com.