This is a staging environment. For live and up-to-date package information, visit swiftpackageindex.com.

The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build SPIndicator with Swift 6.0 (beta) for macOS (SPM).

Build Command

env DEVELOPER_DIR=/Applications/Xcode-15.3.0.app xcrun --toolchain org.swift.600202405261a swift build --arch arm64 -Xswiftc -Xfrontend -Xswiftc -stats-output-dir -Xswiftc -Xfrontend -Xswiftc .stats -Xswiftc -strict-concurrency=complete

Build Log

========================================
RunAll
========================================
Builder version: 4.40.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/ivanvorobei/SPIndicator.git
Reference: main
Initialized empty Git repository in /Users/admin/builder/spi-builder-workspace/.git/
From https://github.com/ivanvorobei/SPIndicator
 * branch            main       -> FETCH_HEAD
 * [new branch]      main       -> origin/main
HEAD is now at 500cb17 Merge pull request #17 from konekoya/main
Cloned https://github.com/ivanvorobei/SPIndicator.git
Revision (git rev-parse @):
500cb17cf2bbd6bdb8eaecb8ee8d1fa737219555
SUCCESS checkout https://github.com/ivanvorobei/SPIndicator.git at main
========================================
Build
========================================
Selected platform:         macosSpm
Swift version:             6.0
Building package at path:  $workDir
https://github.com/ivanvorobei/SPIndicator.git
Running build ...
env DEVELOPER_DIR=/Applications/Xcode-15.3.0.app xcrun --toolchain org.swift.600202405261a swift build --arch arm64 -Xswiftc -Xfrontend -Xswiftc -stats-output-dir -Xswiftc -Xfrontend -Xswiftc .stats -Xswiftc -strict-concurrency=complete
Building for debugging...
[0/2] Write sources
[1/2] Write swift-version-6F35C1178C84523A.txt
[3/15] Compiling SPIndicator SPIndicatorIconPreset.swift
/Users/admin/builder/spi-builder-workspace/Sources/SPIndicator/Extensions/UIColorExtension.swift:22:8: error: no such module 'UIKit'
20 | // SOFTWARE.
21 |
22 | import UIKit
   |        `- error: no such module 'UIKit'
23 |
24 | extension UIColor {
[4/15] Compiling SPIndicator SPIndicator.swift
/Users/admin/builder/spi-builder-workspace/Sources/SPIndicator/Extensions/UIColorExtension.swift:22:8: error: no such module 'UIKit'
20 | // SOFTWARE.
21 |
22 | import UIKit
   |        `- error: no such module 'UIKit'
23 |
24 | extension UIColor {
[5/15] Compiling SPIndicator SPIndicatorIconAnimatable.swift
/Users/admin/builder/spi-builder-workspace/Sources/SPIndicator/Extensions/UIColorExtension.swift:22:8: error: no such module 'UIKit'
20 | // SOFTWARE.
21 |
22 | import UIKit
   |        `- error: no such module 'UIKit'
23 |
24 | extension UIColor {
[6/15] Compiling SPIndicator SPIndicatorView.swift
/Users/admin/builder/spi-builder-workspace/Sources/SPIndicator/Extensions/UIColorExtension.swift:22:8: error: no such module 'UIKit'
20 | // SOFTWARE.
21 |
22 | import UIKit
   |        `- error: no such module 'UIKit'
23 |
24 | extension UIColor {
[7/15] Compiling SPIndicator UIFontExtension.swift
/Users/admin/builder/spi-builder-workspace/Sources/SPIndicator/Extensions/UIColorExtension.swift:22:8: error: no such module 'UIKit'
20 | // SOFTWARE.
21 |
22 | import UIKit
   |        `- error: no such module 'UIKit'
23 |
24 | extension UIColor {
[8/15] Compiling SPIndicator UILabelExtension.swift
/Users/admin/builder/spi-builder-workspace/Sources/SPIndicator/Extensions/UIColorExtension.swift:22:8: error: no such module 'UIKit'
20 | // SOFTWARE.
21 |
22 | import UIKit
   |        `- error: no such module 'UIKit'
23 |
24 | extension UIColor {
[9/16] Compiling SPIndicator SPIndicatorHaptic.swift
/Users/admin/builder/spi-builder-workspace/Sources/SPIndicator/Extensions/UIColorExtension.swift:22:8: error: no such module 'UIKit'
20 | // SOFTWARE.
21 |
22 | import UIKit
   |        `- error: no such module 'UIKit'
23 |
24 | extension UIColor {
[10/16] Compiling SPIndicator SPIndicatorLayout.swift
/Users/admin/builder/spi-builder-workspace/Sources/SPIndicator/Extensions/UIColorExtension.swift:22:8: error: no such module 'UIKit'
20 | // SOFTWARE.
21 |
22 | import UIKit
   |        `- error: no such module 'UIKit'
23 |
24 | extension UIColor {
[11/16] Compiling SPIndicator SPAlertIconErrorView.swift
/Users/admin/builder/spi-builder-workspace/Sources/SPIndicator/Extensions/UIColorExtension.swift:22:8: error: no such module 'UIKit'
20 | // SOFTWARE.
21 |
22 | import UIKit
   |        `- error: no such module 'UIKit'
23 |
24 | extension UIColor {
[12/16] Compiling SPIndicator SPIndicatorIconDoneView.swift
/Users/admin/builder/spi-builder-workspace/Sources/SPIndicator/Extensions/UIColorExtension.swift:22:8: error: no such module 'UIKit'
20 | // SOFTWARE.
21 |
22 | import UIKit
   |        `- error: no such module 'UIKit'
23 |
24 | extension UIColor {
[13/16] Compiling SPIndicator SPIndicatorPresentSide.swift
/Users/admin/builder/spi-builder-workspace/Sources/SPIndicator/Extensions/UIColorExtension.swift:22:8: error: no such module 'UIKit'
20 | // SOFTWARE.
21 |
22 | import UIKit
   |        `- error: no such module 'UIKit'
23 |
24 | extension UIColor {
error: emit-module command failed with exit code 1 (use -v to see invocation)
[14/16] Emitting module SPIndicator
/Users/admin/builder/spi-builder-workspace/Sources/SPIndicator/Extensions/UIColorExtension.swift:22:8: error: no such module 'UIKit'
20 | // SOFTWARE.
21 |
22 | import UIKit
   |        `- error: no such module 'UIKit'
23 |
24 | extension UIColor {
[15/16] Compiling SPIndicator SwiftUIExtension.swift
/Users/admin/builder/spi-builder-workspace/Sources/SPIndicator/Extensions/UIColorExtension.swift:22:8: error: no such module 'UIKit'
20 | // SOFTWARE.
21 |
22 | import UIKit
   |        `- error: no such module 'UIKit'
23 |
24 | extension UIColor {
[16/16] Compiling SPIndicator UIColorExtension.swift
/Users/admin/builder/spi-builder-workspace/Sources/SPIndicator/Extensions/UIColorExtension.swift:22:8: error: no such module 'UIKit'
20 | // SOFTWARE.
21 |
22 | import UIKit
   |        `- error: no such module 'UIKit'
23 |
24 | extension UIColor {
BUILD FAILURE 6.0 macosSpm
This is a staging environment. For live and up-to-date package information, visit swiftpackageindex.com.