This is a staging environment. For live and up-to-date package information, visit swiftpackageindex.com.

The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build AlertKit with Swift 6.0 (beta) for Linux.

Build Command

bash -c docker run --rm -v "checkouts-4609320-1":/host -w "$workDir" registry.gitlab.com/finestructure/spi-images:basic-6.0-latest swift build --triple x86_64-unknown-linux-gnu -Xswiftc -Xfrontend -Xswiftc -stats-output-dir -Xswiftc -Xfrontend -Xswiftc .stats -Xswiftc -strict-concurrency=complete 2>&1

Build Log

========================================
RunAll
========================================
Builder version: 4.40.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/sparrowcode/AlertKit.git
Reference: v5
Initialized empty Git repository in /host/spi-builder-workspace/.git/
hint: Using 'master' as the name for the initial branch. This default branch name
hint: is subject to change. To configure the initial branch name to use in all
hint: of your new repositories, which will suppress this warning, call:
hint:
hint: 	git config --global init.defaultBranch <name>
hint:
hint: Names commonly chosen instead of 'master' are 'main', 'trunk' and
hint: 'development'. The just-created branch can be renamed via this command:
hint:
hint: 	git branch -m <name>
From https://github.com/sparrowcode/AlertKit
 * branch            v5         -> FETCH_HEAD
 * [new branch]      v5         -> origin/v5
HEAD is now at 3b73be8 Merge pull request #72 from alpaycli/ReadableInit
Cloned https://github.com/sparrowcode/AlertKit.git
Revision (git rev-parse @):
3b73be8db5a7e7efaf474c6ed919f5a437d843c9
SUCCESS checkout https://github.com/sparrowcode/AlertKit.git at v5
========================================
Build
========================================
Selected platform:         linux
Swift version:             6.0
Building package at path:  $workDir
https://github.com/sparrowcode/AlertKit.git
Running build ...
bash -c docker run --rm -v "checkouts-4609320-1":/host -w "$workDir" registry.gitlab.com/finestructure/spi-images:basic-6.0-latest swift build --triple x86_64-unknown-linux-gnu -Xswiftc -Xfrontend -Xswiftc -stats-output-dir -Xswiftc -Xfrontend -Xswiftc .stats -Xswiftc -strict-concurrency=complete 2>&1
Building for debugging...
[0/2] Write sources
[1/2] Write swift-version-24593BA9C3E375BF.txt
error: emit-module command failed with exit code 1 (use -v to see invocation)
[3/17] Emitting module AlertKit
/host/spi-builder-workspace/Sources/AlertKit/AlertHaptic.swift:1:8: error: no such module 'UIKit'
 1 | import UIKit
   |        `- error: no such module 'UIKit'
 2 |
 3 | public enum AlertHaptic {
[4/17] Compiling AlertKit AlertKitAPI.swift
/host/spi-builder-workspace/Sources/AlertKit/AlertHaptic.swift:1:8: error: no such module 'UIKit'
 1 | import UIKit
   |        `- error: no such module 'UIKit'
 2 |
 3 | public enum AlertHaptic {
[5/17] Compiling AlertKit AlertViewStyle.swift
/host/spi-builder-workspace/Sources/AlertKit/AlertHaptic.swift:1:8: error: no such module 'UIKit'
 1 | import UIKit
   |        `- error: no such module 'UIKit'
 2 |
 3 | public enum AlertHaptic {
[6/17] Compiling AlertKit AlertHaptic.swift
/host/spi-builder-workspace/Sources/AlertKit/AlertHaptic.swift:1:8: error: no such module 'UIKit'
 1 | import UIKit
   |        `- error: no such module 'UIKit'
 2 |
 3 | public enum AlertHaptic {
[7/17] Compiling AlertKit AlertIcon.swift
/host/spi-builder-workspace/Sources/AlertKit/AlertHaptic.swift:1:8: error: no such module 'UIKit'
 1 | import UIKit
   |        `- error: no such module 'UIKit'
 2 |
 3 | public enum AlertHaptic {
[8/18] Compiling AlertKit AlertViewProtocol.swift
/host/spi-builder-workspace/Sources/AlertKit/AlertHaptic.swift:1:8: error: no such module 'UIKit'
 1 | import UIKit
   |        `- error: no such module 'UIKit'
 2 |
 3 | public enum AlertHaptic {
[9/18] Compiling AlertKit AlertAppleMusic17View.swift
/host/spi-builder-workspace/Sources/AlertKit/AlertHaptic.swift:1:8: error: no such module 'UIKit'
 1 | import UIKit
   |        `- error: no such module 'UIKit'
 2 |
 3 | public enum AlertHaptic {
[10/18] Compiling AlertKit AlertViewInternalDismissProtocol.swift
/host/spi-builder-workspace/Sources/AlertKit/AlertHaptic.swift:1:8: error: no such module 'UIKit'
 1 | import UIKit
   |        `- error: no such module 'UIKit'
 2 |
 3 | public enum AlertHaptic {
[11/18] Compiling AlertKit UILabelExtension.swift
/host/spi-builder-workspace/Sources/AlertKit/AlertHaptic.swift:1:8: error: no such module 'UIKit'
 1 | import UIKit
   |        `- error: no such module 'UIKit'
 2 |
 3 | public enum AlertHaptic {
[12/18] Compiling AlertKit AlertIconDoneView.swift
/host/spi-builder-workspace/Sources/AlertKit/AlertHaptic.swift:1:8: error: no such module 'UIKit'
 1 | import UIKit
   |        `- error: no such module 'UIKit'
 2 |
 3 | public enum AlertHaptic {
[13/18] Compiling AlertKit SwiftUIExtension.swift
/host/spi-builder-workspace/Sources/AlertKit/AlertHaptic.swift:1:8: error: no such module 'UIKit'
 1 | import UIKit
   |        `- error: no such module 'UIKit'
 2 |
 3 | public enum AlertHaptic {
[14/18] Compiling AlertKit UIFontExtension.swift
/host/spi-builder-workspace/Sources/AlertKit/AlertHaptic.swift:1:8: error: no such module 'UIKit'
 1 | import UIKit
   |        `- error: no such module 'UIKit'
 2 |
 3 | public enum AlertHaptic {
[15/18] Compiling AlertKit AlertSpinnerView.swift
/host/spi-builder-workspace/Sources/AlertKit/AlertHaptic.swift:1:8: error: no such module 'UIKit'
 1 | import UIKit
   |        `- error: no such module 'UIKit'
 2 |
 3 | public enum AlertHaptic {
[16/18] Compiling AlertKit AlertAppleMusic16View.swift
/host/spi-builder-workspace/Sources/AlertKit/AlertHaptic.swift:1:8: error: no such module 'UIKit'
 1 | import UIKit
   |        `- error: no such module 'UIKit'
 2 |
 3 | public enum AlertHaptic {
[17/18] Compiling AlertKit AlertIconErrorView.swift
/host/spi-builder-workspace/Sources/AlertKit/AlertHaptic.swift:1:8: error: no such module 'UIKit'
 1 | import UIKit
   |        `- error: no such module 'UIKit'
 2 |
 3 | public enum AlertHaptic {
[18/18] Compiling AlertKit AlertIconHeartView.swift
/host/spi-builder-workspace/Sources/AlertKit/AlertHaptic.swift:1:8: error: no such module 'UIKit'
 1 | import UIKit
   |        `- error: no such module 'UIKit'
 2 |
 3 | public enum AlertHaptic {
BUILD FAILURE 6.0 linux
This is a staging environment. For live and up-to-date package information, visit swiftpackageindex.com.