This is a staging environment. For live and up-to-date package information, visit swiftpackageindex.com.

The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build Kuri with Swift 5.9 for iOS using Xcode 15.2 at 0.5.0.

Build Command

env DEVELOPER_DIR="/Applications/Xcode-15.0.0-Beta.2.app" xcrun xcodebuild -IDEClonedSourcePackagesDirPathOverride="$PWD/.dependencies" -derivedDataPath "$PWD/.derivedData" build -scheme KuriDemo -destination "generic/platform=ios"

Build Log

========================================
RunAll
========================================
Builder version: 4.22.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/bannzai/kuri.git
Reference: 0.5.0
Initialized empty Git repository in /Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/bannzai/kuri
 * tag               0.5.0      -> FETCH_HEAD
HEAD is now at 4f89c4b Merge pull request #24 from hicka04/fix/install/swiftpm-swift5.3
Cloned https://github.com/bannzai/kuri.git into spi-builder-workspace
4f89c4b56c085e01de8e046bc3af9bbf5021474b
SUCCESS checkout https://github.com/bannzai/kuri.git at 0.5.0
========================================
Build
========================================
Selected platform:         iOS
Swift version:             5.9
Building package at path:  spi-builder-workspace
Command line invocation:
    /Applications/Xcode-15.0.0-Beta.2.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -resolvePackageDependencies

User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEPackageSupportUseBuiltinSCM = YES
Resolve Package Graph

Fetching from https://github.com/bannzai/Gedatsu (cached)

Creating working copy of package ‘Gedatsu’

Checking out 1.2.0 of package ‘Gedatsu’


Resolved source packages:
  Gedatsu: https://github.com/bannzai/Gedatsu @ 1.2.0

resolved source packages: Gedatsu
{
  "workspace" : {
    "name" : "Kuri",
    "schemes" : [
      "KuriDemo"
    ]
  }
}
Running build ...
env DEVELOPER_DIR="/Applications/Xcode-15.0.0-Beta.2.app" xcrun xcodebuild -IDEClonedSourcePackagesDirPathOverride="$PWD/.dependencies" -derivedDataPath "$PWD/.derivedData" build -scheme KuriDemo -destination "generic/platform=ios"
Command line invocation:
    /Applications/Xcode-15.0.0-Beta.2.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -derivedDataPath /Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData build -scheme KuriDemo -destination generic/platform=ios

User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEDerivedDataPathOverride = /Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData
    IDEPackageSupportUseBuiltinSCM = YES
Resolve Package Graph


Resolved source packages:
  Gedatsu: https://github.com/bannzai/Gedatsu @ 1.2.0
Prepare packages

Computing target dependency graph and provisioning inputs

Create build description
Build description signature: c1d2e59fc9ada799d424efc180604f58
Build description path: /Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData/Build/Intermediates.noindex/XCBuildData/c1d2e59fc9ada799d424efc180604f58.xcbuilddata

note: Building targets in dependency order
note: Target dependency graph (3 targets)
    Target 'KuriDemo' in project 'KuriDemo'
        ➜ Explicit dependency on target 'Gedatsu' in project 'Gedatsu'
    Target 'Gedatsu' in project 'Gedatsu'
        ➜ Explicit dependency on target 'Gedatsu' in project 'Gedatsu'
    Target 'Gedatsu' in project 'Gedatsu' (no dependencies)
/Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/KuriDemo/KuriDemo.xcodeproj: warning: The iOS deployment target 'IPHONEOS_DEPLOYMENT_TARGET' is set to 11.1, but the range of supported deployment target versions is 12.0 to 17.0.99. (in target 'KuriDemo' from project 'KuriDemo')
/Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/KuriDemo/KuriDemo.xcodeproj: error: Signing for "KuriDemo" requires a development team. Select a development team in the Signing & Capabilities editor. (in target 'KuriDemo' from project 'KuriDemo')
** BUILD FAILED **
ShellOut encountered an error
Status code: 65
Message: "** BUILD FAILED **
"
Output: "Command line invocation:
    /Applications/Xcode-15.0.0-Beta.2.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -derivedDataPath /Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData build -scheme KuriDemo -destination generic/platform=ios

User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEDerivedDataPathOverride = /Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData
    IDEPackageSupportUseBuiltinSCM = YES

Resolve Package Graph


Resolved source packages:
  Gedatsu: https://github.com/bannzai/Gedatsu @ 1.2.0

Prepare packages

Computing target dependency graph and provisioning inputs

Create build description
Build description signature: c1d2e59fc9ada799d424efc180604f58
Build description path: /Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData/Build/Intermediates.noindex/XCBuildData/c1d2e59fc9ada799d424efc180604f58.xcbuilddata

note: Building targets in dependency order
note: Target dependency graph (3 targets)
    Target 'KuriDemo' in project 'KuriDemo'
        ➜ Explicit dependency on target 'Gedatsu' in project 'Gedatsu'
    Target 'Gedatsu' in project 'Gedatsu'
        ➜ Explicit dependency on target 'Gedatsu' in project 'Gedatsu'
    Target 'Gedatsu' in project 'Gedatsu' (no dependencies)
/Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/KuriDemo/KuriDemo.xcodeproj: warning: The iOS deployment target 'IPHONEOS_DEPLOYMENT_TARGET' is set to 11.1, but the range of supported deployment target versions is 12.0 to 17.0.99. (in target 'KuriDemo' from project 'KuriDemo')
/Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/KuriDemo/KuriDemo.xcodeproj: error: Signing for "KuriDemo" requires a development team. Select a development team in the Signing & Capabilities editor. (in target 'KuriDemo' from project 'KuriDemo')"
Retrying in 0.0 seconds ...
Building ... (attempt 2)
Command line invocation:
    /Applications/Xcode-15.0.0-Beta.2.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -derivedDataPath /Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData build -scheme KuriDemo -destination generic/platform=ios

User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEDerivedDataPathOverride = /Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData
    IDEPackageSupportUseBuiltinSCM = YES
Resolve Package Graph


Resolved source packages:
  Gedatsu: https://github.com/bannzai/Gedatsu @ 1.2.0
Prepare packages

Computing target dependency graph and provisioning inputs

Create build description

note: Building targets in dependency order
note: Target dependency graph (3 targets)
    Target 'KuriDemo' in project 'KuriDemo'
        ➜ Explicit dependency on target 'Gedatsu' in project 'Gedatsu'
    Target 'Gedatsu' in project 'Gedatsu'
        ➜ Explicit dependency on target 'Gedatsu' in project 'Gedatsu'
    Target 'Gedatsu' in project 'Gedatsu' (no dependencies)
/Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/KuriDemo/KuriDemo.xcodeproj: error: Signing for "KuriDemo" requires a development team. Select a development team in the Signing & Capabilities editor. (in target 'KuriDemo' from project 'KuriDemo')
/Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/KuriDemo/KuriDemo.xcodeproj: warning: The iOS deployment target 'IPHONEOS_DEPLOYMENT_TARGET' is set to 11.1, but the range of supported deployment target versions is 12.0 to 17.0.99. (in target 'KuriDemo' from project 'KuriDemo')
** BUILD FAILED **
ShellOut encountered an error
Status code: 65
Message: "** BUILD FAILED **
"
Output: "Command line invocation:
    /Applications/Xcode-15.0.0-Beta.2.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -derivedDataPath /Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData build -scheme KuriDemo -destination generic/platform=ios

User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEDerivedDataPathOverride = /Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData
    IDEPackageSupportUseBuiltinSCM = YES

Resolve Package Graph


Resolved source packages:
  Gedatsu: https://github.com/bannzai/Gedatsu @ 1.2.0

Prepare packages

Computing target dependency graph and provisioning inputs

Create build description

note: Building targets in dependency order
note: Target dependency graph (3 targets)
    Target 'KuriDemo' in project 'KuriDemo'
        ➜ Explicit dependency on target 'Gedatsu' in project 'Gedatsu'
    Target 'Gedatsu' in project 'Gedatsu'
        ➜ Explicit dependency on target 'Gedatsu' in project 'Gedatsu'
    Target 'Gedatsu' in project 'Gedatsu' (no dependencies)
/Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/KuriDemo/KuriDemo.xcodeproj: error: Signing for "KuriDemo" requires a development team. Select a development team in the Signing & Capabilities editor. (in target 'KuriDemo' from project 'KuriDemo')
/Users/builder/builds/TDmZkXJm/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/KuriDemo/KuriDemo.xcodeproj: warning: The iOS deployment target 'IPHONEOS_DEPLOYMENT_TARGET' is set to 11.1, but the range of supported deployment target versions is 12.0 to 17.0.99. (in target 'KuriDemo' from project 'KuriDemo')"
BUILD FAILURE 5.9 iOS
This is a staging environment. For live and up-to-date package information, visit swiftpackageindex.com.