This is a staging environment. For live and up-to-date package information, visit swiftpackageindex.com.

The Swift Package Index logo.Swift Package Index

Supporting Swift 5.9 Betas


Back in April, we were proud to announce that we supported Swift 5.8 within one week of the official release, adding it to our compatibility matrix so you could know whether the package you were considering would work with the latest version of Swift.

How could we improve on adding support for a new Swift version after just one week of it being available? We could add support for Swift 5.9 one week after the release of the first beta version!

So, that’s the announcement! The Swift Package Index now supports Swift 5.9 packages and will soon show macro products contained within them.

A build compatibility matrix showing compatibility with Swift 5.9.

We also support building documentation with Swift 5.9, but as it’s still in beta, we have made that opt-in for now. If you’d like to build your package documentation with 5.9, you can let us know via a .spi.yml manifest file in your package’s repository.

Note: For the next few days, you may see question mark icons against the Swift 5.9 beta column in the matrix. Please bear with us while our systems process the build backlog.


About this blog

The Swift Package Index is a search engine and metadata index for Swift packages. Our main goal is to help you make better decisions about the dependencies you include in your apps and projects. If you're new here, the best place to get started is by searching for packages.
This is a staging environment. For live and up-to-date package information, visit swiftpackageindex.com.